使用vim编辑器编辑/etc/config/network. 命令如下:
- vim /etc/config/network
- config interface 'loopback'
- option ifname 'lo'
- option proto 'static'
- option ipaddr '127.0.0.1'
- option netmask '255.0.0.0'
- config interface 'lan'
- # option ifname 'eth0'
- option type 'bridge'
- option proto 'static'
- option ipaddr '192.168.1.1'
- option netmask '255.255.255.0'
- config interface 'wan'
- option ifname 'eth0'
- option proto 'pppoe'
- option username '宽带账号'
- option password '宽带密码'
在这里你要自己注释掉lan中对于eth0的声明。然后在自行定义一个wan,作为上行的通道。
配置完毕之后进行无线WIFI的配置。
- vim /etc/config/wireless
- config wifi-device radio0
- option type mac80211
- option channel 11
- option hwmode 11ng
- option path 'platform/ar933x_wmac'
- option htmode HT20
- list ht_capab SHORT-GI-20
- list ht_capab SHORT-GI-40
- list ht_capab RX-STBC1
- list ht_capab DSSS_CCK-40
- # REMOVE THIS LINE TO ENABLE WIFI:
- # option disabled 1
- config wifi-iface
- option device radio0
- option network lan
- option mode ap
- option ssid xxxxxxxWIFI名称
- option encryption psk2
- option key xxxxxxxxx密码
在wifi的配置界面我们首先要注释掉对wifi禁用的功能--option disabled 1